Friday, December 17, 2010

Event ID 3760 SharePoint job searching for non-existing or deleted SQL database

EventID 3760 for a Database that no longer exists


SQL Database 'eof_SP2010_Search_01_AdminDB_CrawlStore' on SQL Server instance 'SQLcluster' not found. Additional error information from SQL Server is included below.

Cannot open database "eof_SP2010_Search_01_AdminDB_CrawlStore" requested by the login. The login failed.

Login failed for user 'MSFTHOSTING\svcSP2010farm'.

The database was removed within SQL2008 but it looks like some kind of job still searches for this database….


In Central Admin;

Use PowerShell;


2 entries for eof_SP2010_Search_01…. (so SP2010 thinks these DBs are still in but I deleted the SQL DBs

Copy the ID

eof_SP2010_Search_01_... 712fa46e-8df0-4642-9351-f9d663138f8e

eof_SP2010_Search_01_... ae01e1b9-5b0c-4cdb-bb2d-b03cace6abdb


Type $bad = get-spdatabase <your id> and press enter.

PS C:\Users\admjgr> $bad = get-spdatabase 712fa46e-8df0-4642-9351-f9d663138f8e

Type $bad and hit enter. This will show you the database you have in the variable. It is your last chance to double check you got the correct database

PS C:\Users\admjgr> $bad

Output: Name Id Type

---- -- ----

eof_SP2010_Search_01_... 712fa46e-8df0-4642-9351-f9d663138f8e Microsoft.Office....

Type $bad.Delete() and press enter

PS C:\Users\admjgr> $bad.Delete()

The database gets deleted!


Check by typing get-spdatabase within PowerShell again

Database is gone!!

Also done for the other one.

Critical errormessages in Event Viewer are gone now..

The view in Database Upgrade Status also does not show the not responding databases any longer




Thursday, December 16, 2010

PeoplePicker in SharePoint 2010

People Picker in SharePoint 2010


The people-picker is a SharePoint interface responsible for querying repositories for identities or groups in order to grant them permission in the SharePoint application. Site administrators and other users use the People Picker Web control to select people and groups when assigning permissions. There are two possible ways to add users, via the checkname or via the browse feature.

The checkname is the icon with a messenger guy and a checkmark :

The browse feature is the book icon:

How to configure SP2010 to resolve accountnames from other domain(s)


If there's a full 2-way Trust between the domains account name resolving should be ok by default.

If there's a one-way trust (or a two-way trust with selective authentication; you need to configure additional stuff

First, we set an encryption key (execute this on each server in the farm):

stsadm -o setapppassword -password ******

Second, we register all the domains that need to be searched for account names (this is done per Web Application, not per server)

stsadm -o setproperty -pn peoplepicker-searchadforests -pv "domain:domainB.local;domain:domainA.local,domainA\account,password" -url http://webapplication

Don't forget the " "


Stsadm –o setproperty –pn peoplepicker-searchadforests –pv "domain:msfthosting.local(source domain); you want to search in),e-office\!saTrust,xxxxx" –url

The account which is used for the domain you want to search in doesn't matter as long as it exists in the domain you want to search in

To check which value has been set for the PeoplePicker-searchadforests

stsadm -o getproperty -pn peoplepicker-searchadforests -url

Output should be:

<Property Exist="Yes" Value="domain:msfthosting.local;,

e-office\!saTrust,*****" />PS C:\Users\admjgr>


If you want to remove the value which is defined for the peoplepicker-searchadforests

Stsadm –o setproperty –pn peoplepicker-searchadforests –pv "" -url "name of the URL"

Example: stsadm –o setproperty –pn peoplepicker-searchadforests –pv "" -url



Thursday, December 2, 2010

No User Profile application available

EventID 5555


Failure trying to sync web application….. no user profile application available


Event ID: 5555

Task Category: User Profiles

Level: Critical


User: MSFTHOSTING\svcSP2010farm

Computer: aw65.msfthosting.local

Failure trying to synch web application 24123a93-fee7-4540-9ad6-9660ccd71a9d, ContentDB e0d1fe1b-7c22-4d93-a635-95ec4766a8b0 Exception message was Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: No User Profile Application available to service the request. Contact your farm administrator.


The FIM Client is located at C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\UIShell\miisclient.exe



SQL Server is a local instance on my SharePoint machine.  I encountered a race condition where the ForeFront Identity Management Service was attempting to start and connect to its databases before SQL Server could bring all the databases online.  FIM gives up and just shuts the service down.

 When FIM is not running, no profiles can be synched, even if you've already created a connection and already successfully run a sync.  When FIM is offline, if  you go to your User Profile Service App and click "Configure Synchronization Connections", it will say that it can't find any.

 When Windows started up, I would see a couple of errors like:

 Log Name:      Application
 Source:        Microsoft.ResourceManagement.ServiceHealthSource
 Date:          8/4/2010 11:24:09 AM
 Event ID:      22
 Task Category: None
 Level:         Error
 Keywords:      Classic
 User:          N/A
 Computer:      <SharePoint 2010 Server>

The Forefront Identity Manager Service cannot connect to the SQL Database Server. The SQL Server could not be contacted.

The connection failure may be due to a network failure, firewall configuration error, or other connection issue. Additionally, the SQL Server connection information could be configured incorrectly.  

Verify that the SQL Server is reachable from the Forefront Identity Manager Service computer. Ensure that SQL Server is running, that the network connection is active, and that the firewall is configured properly.

Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry.


This is slightly different from the ForeFront Identity Manager Event 3 error I saw above.  What would happen is that FIM would try to connect to its database, and fail, and then the service would shut itself off.  Without an error.  This means that, if you set the FIM service to "Restart on error", it would not restart, because no error was thrown.   I ended up setting the FIM service's startup mode to "Automatic (Delayed Start).  I had learned that this mode actually makes the service wait until all the other services whose startup mode is set to "Automatic" are done starting, before it is allowed to start.  This keeps you from having to hack the registry to set service dependencies. 


Note: I have noticed that, even when the FIM service is configured as described in the item above, you may still occasionally see the "Microsoft.ResourceManagement.ServiceHealthSource" Event 22, typically when a sync is beginning or when FIM is starting up.  Then (as far as I know) everything works normally.

I have been seeing some errors that look like this:

 Log Name:      Application
 Source:        Microsoft-SharePoint Products-SharePoint Portal Server
 Date:          8/8/2010 6:11:11 AM
 Event ID:      5555
 Task Category: User Profiles
 Level:         Critical
 User:          Domain\<Farm Service Account>
 Computer:      <SharePoint 2010 Server>
 Failure trying to synch web application <GUID>, ContentDB <GUID>  Exception message was Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: No User Profile Application available to service the request. Contact your farm administrator…

 I have read that this can happen if the local Network Service account doesn't have Read/Execute permission to the C:\Program Files\Microsoft Office Servers\14.0\* folder.  I updated the permissions today and I'll let you know if that works.

Binnen Premium dit Network Service account toegevoegd aan de hierbovengenoemde folder met Read/Execute rechten




The strange thing is that the User Profile Service actually seems to be working fine; data appears to be synchronizing with both my AD connection and with my BCS connection into a Great Plains employee data store. My Sites seem to be functioning correctly, as well. However, I'm concerned that something is going to bite me at some point going forward.

I have checked and can confirm the following:

  • The Upser Profile service account is a domain account with local admin rights, and full rights on the SQL server (db_owner on all SharePoint-related databases). The account also has all rights that should be necessary (as identified in this blog posting
  • The service account also has read & Execute permission on the Program Files\Microsoft Office Servers\14.0 directory structure (not sure if this is needed, but it was mentioned in another blog post that I found (, though I haven't re-booted the box since making this permissions change, so maybe it hasn't applied yet (grasping at straws)




Open Central Admin op de Premium omgeving

Open Application management

Kies Manage Services

Stop de User Profile Synchronization Service en Start deze vervolgens weer

Er verschijnt een login scherm

Voer wachtwoord in: pR6baxut (2x) en start de service


De service zal in eerste instantie niet opstarten maar houdt de status: STARTING

Voer op de server een IISRESET /NOFORCE uit


Hierdoor zal de service wel starten en is t probleem (vooralsnog) opgelost